wiki:levantar_qpdfview_con_poppler-0.47.0

Descargar poppler-0.47.0 desde https://poppler.freedesktop.org/poppler-0.47.0.tar.xz

Compilar e instalar poppler-0.47.0

Podemos guiarnos desde: https://tibisay.cenditel.gob.ve/visorpdf/wiki/descarga_compilaci%C3%B3n_poppler_pruebas

Con poppler-0.47.0 Compilado e Instalado seguimos con:

Descargar qpdfview desde https://launchpad.net/qpdfview/trunk/0.4.16/+download/qpdfview-0.4.16.tar.gz ó directamente con:

$ wget -c https://launchpad.net/qpdfview/trunk/0.4.16/+download/qpdfview-0.4.16.tar.gz

Extraemos el contenido del fichero descargado con:

$ tar -xzvf qpdfview-0.4.16.tar.gz

Nos dejará en nuestro directorio el fichero comprimido y el directorio del paquete

$ ls
/qpdfview-0.4.16
qpdfview-0.4.16.tar.gz

Entramos en el directorio del paquete /qpdfview-0.4.16

$ cd qpdfview-0.4.16/

Copiar el directorio /goo que está en poppler-0.47.0/goo a /usr/local/include/poppler

Copiar todos los .h de poppler-0.47.0/poppler a /usr/local/include/poppler

Librerías que pueden ser requeridas por qpdfview:

build-essential
qt5-default
qttools5-dev-tools
libgl1-mesa-dev
libdjvulibre-dev
libspectre-dev
libpoppler-qt5-dev
libcups2-dev
libqt5svg5-dev

Comenzamos con la compilación y construcción de qpdfview-0.4.16

qpdfview-0.4.16$ lrelease qpdfview.pro
qpdfview-0.4.16$ qmake qpdfview.pro
qpdfview-0.4.16$ make

Nos creará el ejecutable qpdfview lo ejecutamos con:

qpdfview-0.4.16$ ./qpdfview

Nos abrirá el entorno gráfico de qpdfview pero si intetamos abrir un fichero .pdf nos muestra dos errores:

A su vez, en el shell muestra el error:

Could not load plug-in in first attempt: "/home/debian/tmp/qpdfview-0.4.16/libqpdfview_pdf.so" 
"Cannot load library /home/debian/tmp/qpdfview-0.4.16/libqpdfview_pdf.so: (libpoppler-qt4.so.4: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio)" 
Could not load plug-in in second attempt: "" 
"No se ha encontrado la biblioteca compartida." 

Exportamos las librerías compartidas que qpdfview necesita para leer ficheros .pdf

qpdfview-0.4.16$ export LD_LIBRARY_PATH=/usr/local/lib

Levantamos nuevamente qpdfview con:

qpdfview-0.4.16$ ./qpdfview

Intentamos abrir un fichero .pdf

Como poppler-0.47.0 está instalado qpdfview lo reconocerá directamente.

Last modified 22 months ago Last modified on Oct 20, 2016, 3:29:14 PM

Attachments (4)

Download all attachments as: .zip