source: terepaima/terepaima-0.4.16/debian/rules @ 9ebd32a

desarrollostretch
Last change on this file since 9ebd32a was 9ebd32a, checked in by aosorio <aosorio@…>, 8 years ago

agregados nuevos ficheros al directorio debian/

  • Property mode set to 100755
File size: 756 bytes
RevLine 
[1f4adec]1#!/usr/bin/make -f
[1a48de6]2# -*- makefile -*-
[1f4adec]3
4DPKG_EXPORT_BUILDFLAGS = 1
[1a48de6]5include /usr/share/dpkg/buildflags.mk
6export QT_SELECT=qt5
[1f4adec]7
[9ebd32a]8# esta linea permite ignorar la busqueda de un paquete que proporcione
9# una libreria compartida no empaquetada
10override_dh_shlibdeps:
11        dh_shlibdeps --dpkg-shlibdeps-params=--ignore-missing-info
12
[1f4adec]13%:
[1a48de6]14        dh $@ --parallel
[9ebd32a]15#       dh_shlibdeps -l/tmp
[1f4adec]16
[1a48de6]17override_dh_auto_clean:
18        rm -fr miscellaneous/qpdfview.desktop translations/*.qm moc* objects*
19        dh_auto_clean
[1f4adec]20
[1a48de6]21override_dh_auto_configure:
22        lrelease qpdfview.pro
23        qmake DEFINES+="_FILE_OFFSET_BITS=64" QMAKE_CFLAGS="$(CFLAGS) $(CPPFLAGS)" QMAKE_CXXFLAGS="$(CFLAGS) $(CPPFLAGS) $(CXXFLAGS)" QMAKE_LFLAGS="$(LDFLAGS)" qpdfview.pro
[1f4adec]24
[1a48de6]25override_dh_installchangelogs:
[9ebd32a]26        dh_installchangelogs CHANGES
Note: See TracBrowser for help on using the repository browser.